Weekend Auto Racer - Tech Board - Archives

User Note: You can change the order the postings are shown by clicking on the 'Set Preferences' link, from the main index window, and following the directions.

Back To The WAR Homepage.


               


[ View Thread ] [ Return to Index ] [ Read Prev Msg ] [ Read Next Msg ]

WAR Tech Board Archive

Powerglide won't shift into high gear!

Posted By: UFnARacing
Date: 4/9/2004 08:31

OK, I admit it, I need help. Had this trans for all of last year, never had it in high gear, now I need it to be. Runs in reverse, nuetral and low gear just fine, but won't go into high gear. I've checked all the obvious things, linkage, vaccum modulator, all the valves in the valve body are moving easily.

I am going to go through the governor weights for free movement, but I found something that I suspect. With the help of a book, it looks as though the valve body is for a rear pump model. My serial number shows that mine is front pump only. I'm not sure if you can put a rear pump into this case, I think so, but haven't checked yet. Will this valve body still work, if I remove the check valves that are required for a rear pump model?

Any help is very much appreciated.

http://webpages.charter.net/ufnaracing

Messages In This Thread

Powerglide won't shift into high gear! -- UFnARacing -- 4/9/2004 08:31
Re: Powerglide won't shift into high gear! -- Burt -- 4/9/2004 14:23
Re: Powerglide won't shift into high gear! -- UFnARacing -- 4/9/2004 14:49
Re: Powerglide won't shift into high gear! -- Burt -- 4/9/2004 20:00
Re: Powerglide won't shift into high gear! -- UFnARacing -- 4/11/2004 18:26
Re: Powerglide won't shift into high gear! -- Burt -- 4/12/2004 04:55

[ View Thread ] [ Return to Index ] [ Read Prev Msg ] [ Read Next Msg ]

WAR Tech Board Archive is maintained by WAR Administrator with WebBBS 5.11.



Don't forget to check out auto-ware.com for your racing software needs!
Email us at: autoware@aol.com